Power Stack

အရင်က ဒီနေရာမှာ Switch Stacking အကြောင်းရေးထားဖူးတယ်။ ဒီတစ်ခါတော့ power stacking အကြောင်းပေါ့။ အရင်တုန်းက ထင်ထားတာ data stacking လိုပဲ switch 9 လုံးအထိ အဆင်ပြေတယ်လိုပဲ။ ဒါပေမယ့် solar wind ကနေ ကြည့်လိုက်တော့ တချို့ power port တွေက အလုပ်မလုပ်ဖူးလို့ ပြနေတယ်။ အဲဒါနဲ့ လိုက်ရှာကြည့်လိုက်တော့ cisco က power stack ကို switch ၄ လုံးအထိပဲ support လုပ်တယ်လို့ တွေ့ရော။ အဲဒါနဲ့ switch ၄ လုံးထက်ပိုတဲ့ stack ဆိုရင် power အတွက် ‌switch ၄ လုံးကို power stack တစ်ခု နောက်ထပ် switch တွေကို နောက်ထပ် power stack တစ်ခု ထပ်ခွဲရတယ်။ တကယ်လို့ တချို့ port တွေက shutdown ဖြစ်နေရင် အောက်က ကွန်မန်းလေးနဲ့ unshut ပြန်လုပ်လို့ရတယ်။

stack-power switch x port 1 enable

stack-power switch x port 2 enable

x ဆိုတာကတော့ switch number

#show stack-power neighbors
Power Stack Stack Stack Total Rsvd Alloc Unused Num Num
Name Mode Topolgy Pwr(W) Pwr(W) Pwr(W) Pwr(W) SW PS
——————– —— ——- —— —— —— —— — —
Powerstack-11 SP-PS Ring 2800 1680 1120 0 4 8
Powerstack-15 SP-PS Ring 2100 1260 840 0 3 6

Power Stack Port 1 Port 1 Port 2 Port 2
SW Name Status Neighbor SW:MAC Status Neighbor SW:MAC
— ——————– —— —————- —— —————-
1 Powerstack-11 Conn 2:2852.xxx2.xxx2 Conn 4:2852.xxx1.xxx1
2 Powerstack-11 Conn 3:2c0b.xxx3.xxx3 Conn 1:2852.xxx4.xxx4
3 Powerstack-11 Conn 4:2852.xxx1.xxx1 Conn 2:2852.xxx2.xxx2
4 Powerstack-11 Conn 1:2852.xxx4.xxx4 Conn 3:2c0b.xxx3.xxx3
5 Powerstack-15 Conn 6:2852.xxx5.xxx5 Conn 7:2852.xxx6.xxx6
6 Powerstack-15 Conn 7:2852.xxx6.xxx6 Conn 5:2852.xxx7.xxx7
7 Powerstack-15 Conn 5:2852.xxx7.xxx7 Conn 6:2852.xxx5.xxx5

ဒီနေရာမှာ xxx ဆိုတာကတော့ မူရင်း mac address တွေကို ပြင်ထားတာပါ။

 

CCNP DataCenter

ဒီနေ့အီးမေးလာလို့ ကြည့်လိုက် CCNP Datacenter စာမေးပွဲက version 5 ကနေ version 6 ကို ပြောင်းသွားပါပြီ။

Version 5 နဲ့ Version 6  ကွာခြားချက်ကို အောက်က table မှာ ကြည့်နိုင်ပါတယ်။

Current Version 5.0 Exams New Version 6.0 Exams
Last day to test using v5.0 exams is July 3, 2017
642-999 DCUCI Exam 300-175 DCUCI
642-997 DCUFI Exam 300-165 DCII
642-998 DCUCD Exam 300-160 DCID
642-996 DCUFD Exam
642-035 DCUCT Exam 300-180 DCIT
642-980 DCUFT Exam
300-170 DCVAI – This additional exam is required if candidates choose to take any version 6.0 exams

အသေးစိတ်သိချင်ရင်တော့ အောက်ကလင့်မှာ ကြည့်နိုင်ပါတယ်။

https://learningnetwork.cisco.com/community/certifications/ccnp_data_center?utm_source=marketo&utm_campaign=DC_launch&utm_medium=email&mkt_tok=eyJpIjoiTjJSbFkySXdaRGRoWm1SaCIsInQiOiJMZXBqeXJIb0FEaHVrSTVQaExGR2dBRHgzMmh5T0U0b2pCeUFXTDBVeGRWSFJRYWlMVTcxZkFlMHFHaE03Y05WUXA2dVVDbFNlNGlPNkNSV050NHkreFdveWhuaklodHZpRjg0R1lOdGlpR01kWVo2NzY3SVBtVm51eWRzbFwvQU0ifQ%3D%3D

Dynamic NAT

Dynamic NAT ကတော့ NAT overload နဲ့ သိပ်ပြီးမကွာပါဘူး။ အဓိက ကွာခြားချက်က NAT overload က public ip address တစ်ခုထဲကိုပဲသုံးတယ်။ dynamic NAT ကတော့ public ip address ၂ ခုနဲ့ အထက်ကို သုံးပြီး အင်တာနက်ကို access လုပ်တာပါ။

dynamic_nat

ဒီပုံလေးအတိုင်း setup လုပ်ပြီးတော့ R1 မှာ အောက်အတိုင်း configure လုပ်ပြီးတော့ပဲ စမ်းကြည့်လိုက်ပါတော့။

ip nat pool NAT-POOL 172.16.12.10 172.16.12.20 netmask 255.255.255.0
ip nat inside source list 1 pool NAT-POOL
access-list 1 permit 10.1.1.0 0.0.0.255
int g0/1
ip nat inside
int g0/0
ip nat outside

ဒါကဘာကိုပြောလဲဆိုတော့ LAN အတွက် access-list တစ်ခုလုပ်တယ်။

public IP Address ကို 172.16.12.10 ကနေ 172.16.12.20 range ကို သုံးလိုက်တယ်။ ပြီးရင် နာမည်တစ်ခုပေးပြီးတော့ pool တစ်ခုလုပ်လိုက်တယ်။ ပြီးရင် အဲဒီ pool နာမည်နဲ့ access-list ကို map လုပ်ပေးလိုက်တာပါ။

စမ်းကြည့်လိုက်ပါဦး။

Static NAT

static NAT ကိုတော့ ဘယ်လိုမျိုးနေရာမှာသုံးလဲဆိုတော့ ကိုယ့် network ထဲမှာရှိတဲ့ Server တစ်ခုခုက ဆားဗစ်တစ်ခုကို အပြင်ကနေ access လုပ်ချင်ရင် သုံးပါတယ်။

static_nat

 

ဒီထဲကပုံမှာဆိုရင် ကျွန်တော်တို့ configure လုပ်ပေးရမှာက R1 နောက်မှာရှိတဲ့ web server ကို R2 နောက်မှာရှိတဲ့ PC ကနေ access လုပ်လို့ရအောင် လုပ်ပေးရမှာပါ။ IP address တွေကို ပုံထဲကအတိုင်း configure လုပ်လိုက်မယ်။ ပြီးရင် R1’s Gi0/0 and Gi 0/1 interface အောက်မှာ ip nat outside and ip nat inside command ထည့်လိုက်ပါမယ်။

interface GigabitEthernet0/0
ip address 172.16.12.1 255.255.255.0
ip nat outside

interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
ip nat inside

ပြီးရင် static nat command ကို အောက်ကအတိုင်း global config mode မှာ ထည့်လိုက်ပါမယ်။

ip nat inside source static 192.168.10.10 172.16.12.3

ပြီးရင် PC ကနေ public ip address အနေနဲ့ သုံးထားတဲ့ 172.16.12.3 ကို ဘရောက်ဇာကနေ ခေါ်ကြည့်ရအောင်။

web-1

ခေါ်ကြည့်လို့ရနေပါဘီ။ ping ကြည့်ရအောင်။

ping

ping ကြည့်လို့လဲ ရနေပါတယ်။ အဲဒါဘာလို့လဲဆိုတော့ static nat မှာ IP to IP ပဲ mapping လုပ်ထားလို့ပါ။ port 80 and 443 ကိုပဲ allow လုပ်ကြည့်ရအောင်။

ip nat inside source static 192.168.10.10 172.16.12.3 ကို ဖျက်လိုက်ပြီးတော့ အောက်က ကွန်မန်းတွေကို အစားထိုးပြီးထည့်လိုက်ပါမယ်။

ip nat inside source static tcp 192.168.10.10 80 172.16.12.3 80
ip nat inside source static tcp 192.168.10.10 443 172.16.12.3 443

no_ping

ping လို့မရတော့ပါဘူး။

ဘရောက်ဇာကနေခေါ်ကြည့်ရအောင်။

web_only

ဘရောက်ဇာမှာတော့ အဆင်ပြေပါတယ်။

R1 မှာ ip nat translation ကို ကြည့်ကြည့်ရအောင်။

R1#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
tcp 172.16.12.3:443 192.168.10.10:443 — —
tcp 172.16.12.3:443 192.168.10.10:443 172.16.12.2:1046 172.16.12.2:1046
tcp 172.16.12.3:443 192.168.10.10:443 172.16.12.2:1047 172.16.12.2:1047
tcp 172.16.12.3:80 192.168.10.10:80 — —
tcp 172.16.12.3:80 192.168.10.10:80 172.16.12.2:1045 172.16.12.2:1045
R1#

ဒီပို့ရဲ့အရင်တင်ထားတဲ့ NAT overload (Port address Translation- PAT) နဲ့ အခုပို့ကို တခါထဲ configure လုပ်ပြီးလဲ စမ်းကြည့်နိုင်ပါတယ်။ တဖက်ကို overload configure လုပ်ပြီး တဖက်ကို static NAT configure လုပ်ပြီး စမ်းကြည့်နိုင်ပါတယ်။

 

NAT overload (Port address Translation- PAT)

Cisco Router တွေမှာ NAT configuration ဘယ်လိုလုပ်လဲ ဆိုတာကို လေ့လာကြည့်ရအောင်။

ပထမဆုံး NAT overload ကို ကြည့်ရအောင်။ အဲဒါကို port address translation (PAT) လို့လဲ ခေါ်ပါတယ်။

NAT.png

Topology ကိုတော့ အထက်ကပုံလေးအတိုင်းသုံးလိုက်ပါမယ်။

ဒီပုံလေးမှာ R1, Switch and two PCs ကိုတော့ ကိုယ့်နပ်ဝပ်ထဲက အပိုင်း၊ 172.16.12.0/24 ကိုတော့ public IP Address အနေနဲ့ မြင်ပေးပါ။ ဘာလို့လဲဆိုတော့ ဒီပို့မှာ NAT overload အကြောင်းကို ပြောမှာမို့လို့ပါ။ 172.16.12.3 IP Address ကိုတော့ R2 ကနေ ပိုင်ဆိုင်တဲ့ public ip address အနေနဲ့သုံးထားပါတယ်။

R1 gig0/0 ကို 172.16.12.1/24 လို့ပေးလိုက်မယ်။ R1’s Gig0/1 ကိုတော့ 192.168.10.254/24 လို့ပေးလိုက်ပါမယ်။ အဲဒီတော့ PC တွေရဲ့ default gw တွေက 192.168.10.254 ဖြစ်သွားပါမယ်။

ပထမဆုံး 192.168.10.0/24 က အင်တာနက်ကိုသွားဖို့အတွက် access-list တစ်ခု လုပ်လိုက်ပါမယ်။

access-list 1 permit 192.168.10.0 0.0.0.255

ပြီးရင် R1’s Gi0/0 interface အောက်မှာ ip nat outside ဆိုတဲ့ command ထည့်လိုက်ပါမယ်။ ဘာလို့လဲဆိုတော့ သူက အင်တာနက်ကို တိုက်ရိုက်ချိတ်ထားတဲ့ interface မို့လို့ပါ။

ပြီးရင် R1’s Gi0/1 interface အောက်မှာ ip nat inside ဆိုတဲ့ command ကို ထည့်လိုက်ပါမယ်။ သူကတော့ LAN ကို ချိတ်ထားတဲ့ interface မို့လို့ပါ။

interface GigabitEthernet0/0
ip address 172.16.12.1 255.255.255.0
ip nat outside
!
interface GigabitEthernet0/1
ip address 192.168.10.254 255.255.255.0
ip nat inside

R2 မှာလဲ လိုအပ်တဲ့ configuration တွေလုပ်ထားဖို့လိုပါတယ်။ အဲဒီအကြောင်းကိုတော့ နောက်ပို့မှာ ထပ်ရေးပေးပါမယ်။

ပြီးရင် အောက်ကကွန်မန်းလေးကို R1 ရဲ့ global config mode မှာ ထည့်ပေးဖို့လိုပါတယ်။

ip nat inside source list 1 interface GigabitEthernet0/0 overload

source list 1 ကတော့ စောစောက လုပ်ထားတဲ့ access-list number ပါ။ Gi0/0 ကတော့ အင်တာနက်ဘက်ကို ချိတ်ထားတဲ့ interface ပါ။

ပြီးရင် PC ကနေ web server ကို သွားကြည့်ရအောင်။

web_access.png

အထက်ကပုံလိုမျိုးမြင်ရရင်တော့ အဆင်ပြေပါဘီ။

local ip to public ip translation ကို အောက်က command နဲ့ ပြန်ကြည့်လို့ရပါတယ်။

R1#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
tcp 172.16.12.1:1027 192.168.10.1:1027 172.16.12.3:80 172.16.12.3:80
tcp 172.16.12.1:1031 192.168.10.2:1031 172.16.12.3:80 172.16.12.3:80
tcp 172.16.12.1:1032 192.168.10.2:1032 172.16.12.3:80 172.16.12.3:80
tcp 172.16.12.1:1033 192.168.10.2:1033 172.16.12.3:80 172.16.12.3:80
tcp 172.16.12.1:1034 192.168.10.2:1034 172.16.12.3:80 172.16.12.3:80
tcp 172.16.12.1:1035 192.168.10.2:1035 172.16.12.3:80 172.16.12.3:80
tcp 172.16.12.1:1036 192.168.10.2:1036 172.16.12.3:80 172.16.12.3:80
tcp 172.16.12.1:1037 192.168.10.2:1037 172.16.12.3:80 172.16.12.3:80
tcp 172.16.12.1:1038 192.168.10.2:1038 172.16.12.3:80 172.16.12.3:80
tcp 172.16.12.1:1039 192.168.10.2:1039 172.16.12.3:80 172.16.12.3:80
tcp 172.16.12.1:1040 192.168.10.2:1040 172.16.12.3:80 172.16.12.3:80
tcp 172.16.12.1:1041 192.168.10.2:1041 172.16.12.3:80 172.16.12.3:80
R1#

နောက်ထပ် NAT lab တွေကိုလဲ အချိန်ရရင် ထပ်ရေးပါဦးမယ်။