EIGRP classic vs EIGRP name mode

မနေ့တုန်းက EIGRP name mode ကို စမ်းကြည့်ပြီးတော့ ဒီနေရာမှာတင်ထားတာရှိတယ်

ဒီနေ့ထပ်ပြီးတော့ classic ရော name mode ရော ရောပြီး စမ်းကြည့်တော့ အားလုံးအဆင်ပြေနေတယ်။

အဲဒါနဲ့ ဘာကွာလဲဆိုပြီး ထပ်ရှာကြည့်ပြီး စမ်းကြည့်ဖြစ်တယ်။

topology ကိုတော့ အောက်ကပုံကိုပဲ သုံးထားတယ်။

classicvsnamemode

ပြီးတော့ router တိုင်းမှာ loopback တစ်ခုဆီရှိတယ်။ (1.1.1.1/32, 2.2.2.2/32 and 3.3.3.3/32)

R1 and R2 ကြားက Network ကို 192.168.12.0/24 ကို ပေးထားတယ်။

R2 and R3 ကြားက Network ကို 192.168.23.0/24 ကို ပေးထားတယ်။

R1 and R2 မှာတော့ name mode ကို သုံးထားပြီး R3 မှာတော့ classic mode ကို သုံးထားတယ်။

@R1

R1(config)#key chain CISCO
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string PASSWORD
R1(config-keychain-key)#

R1(config)#router eigrp EIGRP
R1(config-router)#address-family ipv4 automous-system 123
R1(config-router-af)#network 192.168.12.0 0.0.0.255
R1(config-router-af)#net 1.1.1.1 0.0.0.0
R1(config-router-af)#af-interface fa0/0
R1(config-router-af-interface)#authentication mode md5
R1(config-router-af-interface)#authentication key-chain CISCOauthentication key-chain CISCO
R1(config-router-af-interface)#authentication mode md5

@R2

R2(config)#router eigrp EIGRP
R2(config-router)#address-family ipv4 automous-system 123
R2(config-router-af)#network 192.168.12.0 0.0.0.255
R2(config-router-af)#network 192.168.23.0 0.0.0.255
R2(config-router-af)#net 2.2.2.2 0.0.0.0
R2(config-router-af)#af-interface fa0/0
R2(config-router-af-interface)#authentication mode md5
R2(config-router-af-interface)#authentication key-chain CISCOauthentication key-chain CISCO
R2(config-router-af-interface)#authentication mode md5
R2(config-router-af)#af-interface fa0/1
R2(config-router-af-interface)#authentication mode md5
R2(config-router-af-interface)#authentication key-chain CISCOauthentication key-chain CISCO
R2(config-router-af-interface)#authentication mode md5

@R3

R3(config)#key chain CISCO
R3(config-keychain)#key 1
R3(config-keychain-key)#key-string PASSWORD
R3(config)#router eigrp 123
R3(config-router)#network 192.168.23.0 0.0.0.255
R3(config-router)#network 3.3.3.3 0.0.0.0
R3(config-router)#no auto-summary

R3(config)#int fa0/0
R3(config-if)#ip authentication key-chain eigrp 123 CISCO
R3(config-if)#ip authentication mode eigrp 123 md5

အဲဒါတွေပြီးလို့ EIGRP route တွေကို routing table ထဲမှာ စစ်ကြည့်လိုက်ရင် အောက်ကအတိုင်းတွေ့ရပါလိမ့်မယ်။

R1#sh ip route eigrp
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/103040] via 192.168.12.2, 01:04:37, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2713600] via 192.168.12.2, 01:04:32, FastEthernet0/0
D 192.168.23.0/24 [90/153600] via 192.168.12.2, 01:04:37, FastEthernet0/0
R1#
R2#sh ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/103040] via 192.168.12.1, 01:04:44, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2662400] via 192.168.23.3, 01:04:44, FastEthernet0/1
R2#
R3#sh ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/30720] via 192.168.23.2, 01:05:07, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/28160] via 192.168.23.2, 01:05:12, FastEthernet0/0
D 192.168.12.0/24 [90/30720] via 192.168.23.2, 01:05:12, FastEthernet0/0
R3#

ပြီးရင် R1 ကနေ R3 ကို ping test လုပ်ကြည့်ရင် အဆင်ပြေနေပါလိမ့်မယ်။

R1#ping 3.3.3.3 source 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/39/76 ms
R1#

ဒီလိုဆိုရင် eigrp classic နဲ့ eigrp name mode ဘာကွာလဲ ကြည့်ရအောင်။

EIGRP classic မှာဆိုရင် authentication ကတော့ md5 ပဲ support လုပ်တယ်။

R3(config-if)#ip authentication mode eigrp 123 ?
md5 Keyed message digest
R3(config-if)#ip authentication mode eigrp 123

name mode မှာတော့ md5 ရော sha-256 ရော support လုပ်တယ်။

R1(config-router-af-interface)#authentication mode ?
hmac-sha-256 HMAC-SHA-256 Authentication
md5 Keyed message digest
R1(config-router-af-interface)#authentication mode

အဲဒီ name mode ကို ဘယ် version တွေမှာ support လုပ်လဲဆိုတော့ 15.0(1)M, 12.2(33)SRE, 12.2(33)XNE and Cisco IOS XE Release 2.5 နောက်ပိုင်းဗားရှင်းတွေမှာ စပြီးသုံးလို့ရပါတယ်။

 

 

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s