EIGRP classic vs EIGRP name mode

မနေ့တုန်းက EIGRP name mode ကို စမ်းကြည့်ပြီးတော့ ဒီနေရာမှာတင်ထားတာရှိတယ်

ဒီနေ့ထပ်ပြီးတော့ classic ရော name mode ရော ရောပြီး စမ်းကြည့်တော့ အားလုံးအဆင်ပြေနေတယ်။

အဲဒါနဲ့ ဘာကွာလဲဆိုပြီး ထပ်ရှာကြည့်ပြီး စမ်းကြည့်ဖြစ်တယ်။

topology ကိုတော့ အောက်ကပုံကိုပဲ သုံးထားတယ်။

classicvsnamemode

ပြီးတော့ router တိုင်းမှာ loopback တစ်ခုဆီရှိတယ်။ (1.1.1.1/32, 2.2.2.2/32 and 3.3.3.3/32)

R1 and R2 ကြားက Network ကို 192.168.12.0/24 ကို ပေးထားတယ်။

R2 and R3 ကြားက Network ကို 192.168.23.0/24 ကို ပေးထားတယ်။

R1 and R2 မှာတော့ name mode ကို သုံးထားပြီး R3 မှာတော့ classic mode ကို သုံးထားတယ်။

@R1

R1(config)#key chain CISCO
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string PASSWORD
R1(config-keychain-key)#

R1(config)#router eigrp EIGRP
R1(config-router)#address-family ipv4 automous-system 123
R1(config-router-af)#network 192.168.12.0 0.0.0.255
R1(config-router-af)#net 1.1.1.1 0.0.0.0
R1(config-router-af)#af-interface fa0/0
R1(config-router-af-interface)#authentication mode md5
R1(config-router-af-interface)#authentication key-chain CISCOauthentication key-chain CISCO
R1(config-router-af-interface)#authentication mode md5

@R2

R2(config)#router eigrp EIGRP
R2(config-router)#address-family ipv4 automous-system 123
R2(config-router-af)#network 192.168.12.0 0.0.0.255
R2(config-router-af)#network 192.168.23.0 0.0.0.255
R2(config-router-af)#net 2.2.2.2 0.0.0.0
R2(config-router-af)#af-interface fa0/0
R2(config-router-af-interface)#authentication mode md5
R2(config-router-af-interface)#authentication key-chain CISCOauthentication key-chain CISCO
R2(config-router-af-interface)#authentication mode md5
R2(config-router-af)#af-interface fa0/1
R2(config-router-af-interface)#authentication mode md5
R2(config-router-af-interface)#authentication key-chain CISCOauthentication key-chain CISCO
R2(config-router-af-interface)#authentication mode md5

@R3

R3(config)#key chain CISCO
R3(config-keychain)#key 1
R3(config-keychain-key)#key-string PASSWORD
R3(config)#router eigrp 123
R3(config-router)#network 192.168.23.0 0.0.0.255
R3(config-router)#network 3.3.3.3 0.0.0.0
R3(config-router)#no auto-summary

R3(config)#int fa0/0
R3(config-if)#ip authentication key-chain eigrp 123 CISCO
R3(config-if)#ip authentication mode eigrp 123 md5

အဲဒါတွေပြီးလို့ EIGRP route တွေကို routing table ထဲမှာ စစ်ကြည့်လိုက်ရင် အောက်ကအတိုင်းတွေ့ရပါလိမ့်မယ်။

R1#sh ip route eigrp
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/103040] via 192.168.12.2, 01:04:37, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2713600] via 192.168.12.2, 01:04:32, FastEthernet0/0
D 192.168.23.0/24 [90/153600] via 192.168.12.2, 01:04:37, FastEthernet0/0
R1#
R2#sh ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/103040] via 192.168.12.1, 01:04:44, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2662400] via 192.168.23.3, 01:04:44, FastEthernet0/1
R2#
R3#sh ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/30720] via 192.168.23.2, 01:05:07, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/28160] via 192.168.23.2, 01:05:12, FastEthernet0/0
D 192.168.12.0/24 [90/30720] via 192.168.23.2, 01:05:12, FastEthernet0/0
R3#

ပြီးရင် R1 ကနေ R3 ကို ping test လုပ်ကြည့်ရင် အဆင်ပြေနေပါလိမ့်မယ်။

R1#ping 3.3.3.3 source 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/39/76 ms
R1#

ဒီလိုဆိုရင် eigrp classic နဲ့ eigrp name mode ဘာကွာလဲ ကြည့်ရအောင်။

EIGRP classic မှာဆိုရင် authentication ကတော့ md5 ပဲ support လုပ်တယ်။

R3(config-if)#ip authentication mode eigrp 123 ?
md5 Keyed message digest
R3(config-if)#ip authentication mode eigrp 123

name mode မှာတော့ md5 ရော sha-256 ရော support လုပ်တယ်။

R1(config-router-af-interface)#authentication mode ?
hmac-sha-256 HMAC-SHA-256 Authentication
md5 Keyed message digest
R1(config-router-af-interface)#authentication mode

အဲဒီ name mode ကို ဘယ် version တွေမှာ support လုပ်လဲဆိုတော့ 15.0(1)M, 12.2(33)SRE, 12.2(33)XNE and Cisco IOS XE Release 2.5 နောက်ပိုင်းဗားရှင်းတွေမှာ စပြီးသုံးလို့ရပါတယ်။

 

 

 

EIGRP name mode

အရင်တုန်းကတော့ EIGRP ကို ရိုးရိုး configuration လုပ်တာကိုပဲ လေ့လာပြီး စမ်းကြည့်ဖြစ်တယ်။

ဒီနေ့တော့ EIGRP name mode ဆိုတာကို လေ့လာပြီးတော့ စမ်းကြည့်ဖြစ်တယ်။ Topology ကတော့ ရိုးရိုးပဲ Router ၂ လုံးနဲ့ပဲ စမ်းဖြစ်တယ်။

EIGRP-Namemode

ကဲစပြီး Router 1 မှာ configure လုပ်ကြည့်ရအောင်။

fa0/0 interface တေွမှာ 192.168.12.0/24 အတိုင်း R1 မှာ .1 ပြီးတော့ R2 ဘက်မှာ .2 လို့ပေးလိုက်တယ်။ ပြီးတော့ loopback 0 interface တေွကို 1.1.1.1/32 and 2.2.2.2/32 ပေးလိုက်တယ်။

R1(config)#router eigrp EIGRP

R1(config-router)#address-family  ipv4 autonomous-system 12

R1(config-router-af)#network 192.168.12.0

R1(config-router-af)#network 1.1.1.1 0.0.0.0

ပြီးရင် R2 ဘက်မှာ လဲ အဲဒီအတိုင်းပဲ configure လုပ်လိုက်ပြီး network ကို တော့ 2.2.2.2 0.0.0.0 အတိုင်း ကြေငြာလိုက်မယ်။ ပြီးရင် အောက်ကအတိုင်း စစ်ကြည့်လိုက်ရင် အဆင်ပြေပါဘီ။

R2#ping 1.1.1.1 source 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 2.2.2.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/12 ms
R2#

R1#ping 2.2.2.2 source 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms
R1#

အဆင်ပြေရင် စမ်းကြည့်လိုက်ပါဦး။

Happy Labbing!

Things I do after upgrading to Ubuntu 16.04 LTS

Ubuntu 16.04 LTS ကို upgrade လုပ်ပီးတော့ ဘာတွေလုပ်ဖြစ်လဲဆိုတော့

sudo apt-get update လုပ်တယ်။ ပြီးရင် sudo apt-get upgrade လုပ်တယ်။

Launcher ကို ဘေးမှာမထားချင်တော့ အောက်ကို ကွန်မန်းကို ရိုက်ပီးအောက်ကိုထားလိုက်တယ်။

gsettings set com.canonical.Unity.Launcher launcher-position Bottom

ဘေးမှာပြန်ထားချင်ရင် အောက်က ကွန်မန်းကို ရိုက်နိုင်ပါတယ်။

gsettings set com.canonical.Unity.Launcher launcher-position left

ဖွင့်လိုက်တဲ့ software က launcher မှာ ပြနေတယ်။ အဲဒီအိုင်ကွန်ကိုပဲ ပြန်ကလစ်လိုက်ရင် minimise ပြန်လုပ်ချင်တော့ အောက်က ကွန်မန်းကိုရိုက်ပေးလိုက်တယ်။

gsettings set org.compiz.unityshell:/org/compiz/profiles/unity/plugins/unityshell/ launcher-minimize-window true
uget download manager ကို သုံးချင်တော့ အောက်ကအတိုင်း repo add
sudo add-apt-repository ppa:plushuang-tw/uget-stable
ပြီးရင် sudo apt-get update လုပ်ပြီးတော့ အော်ကကွန်မန်းနဲ့အင်စတောလုပ်လိုက်တယ်။
sudo apt-get install uget


BGP (eBGP & iBGP)

screenshot

သိထားတာလေးတွေ မေ့မသွားခင် ပြန်ပြီးစမ်းကြည့်ထားတာပါ။

ဒီမှာတော့ eBGP and iBGP ကို configure လုပ်ထားပါတယ်။

final output ကတော့ router ရဲ့ loopback0 IP address ကနေ တခြားrouterတိုင်းရဲ့ loopback0 IP address ကို ping test လုပ်နိုင်ဖို့ပါ။

eg: R1#ping 8.8.8.8 source 1.1.1.1

Details config and output ကို အောက်ကလင့်မှာဒေါင်းနိုင်ပါတယ်။

BGP configuration (eBGP & iGBP)

Happy Labbing!

 

update android 4.4.4 to 5.0.2 on MotoG 1st Gen

android 4.4.4 ကို တင်ပြီးတာနဲ့ ထပ်ပြီးတော့ system update လုပ်ကြည့်တာ latest ဆိုပြီးတော့ပဲ ပြောနေတယ်။ အင်တာနက်မှာလိုက်ရှာကြည့်တော့ moto G 1st Gen  အတွက် 5.0.2 ထွက်ပြီဆိုပြီးတွေ့တယ်။ ဘယ်လိုလုပ်ရမလဲ လိုက်ရှာပြီးလုပ်ကြည့်တော့ အဆင်ပြေတယ်တာနဲ့ ဘယ်လိုလုပ်ရလဲဆိုတာ ထပ်ပြီးရေးလိုက်တာပါ။

လိုတဲ့ဖိုင်ကို အောက်ကနေဒေါင်းပါ။ သတိပေးချင်တာက ဒီနည်းလမ်းက unmodified stock ROM Asia အတွက်ပဲ အလုပ်လုပ်ပါတယ်။

Blur_Version.220.21.28.falcon_umtsds.AsiaRetail.en.03.zip

ဒေါင်းပြီးရင် ဖုန်းထဲကို ထည့်လိုက်ပါမယ်။

502.png

ပြီးရင် ဖုန်းကို ပါဝါပိတ်လိုက်ပါမယ်။ ပြီးရင် volume up down + power ကို တွဲနှိပ်ပြီး boot loader ထဲကို ဝင်လိုက်ပြီး recovery ကို ရွေးပြီး power up ကို နှိပ်လိုက်ပါမယ်။ အနီရောင် exclamation mark လေးကို စောင့်လိုက်ပါမယ်။ အဲဒါတက်လာပြီဆိုရင် power up + power down + power button ကို တွဲပြီး နှိပ်လိုက်ပါမယ်။

apply update from sd card

ဒီပုံလေးမြင်ရဘီဆိုရင် apply update from sdcard ကို ရွေးပြီး power button ကို နှိပ်လိုက်ပါမယ်။

ပြီးရင် စောစောက ဒေါင်းပြီး ဖုန်းထဲထည့်ထားတဲ့ဖိုင်ကို ရွေးလိုက်ရင် သူ့ဘာသာသူ့ update လုပ်သွားပါလိမ့်မယ်။ မိနစ် ၂၀ ကနေ ၃၀ လောက်စောင့်ပြီးရင် ပြီးပါဘီ။ reboot system now ဆိုတာကို မြင်ရဘီဆိုရင် အဲဒါကို ရွေးပြီး ပါဝါကို နှိပ်ပေးလိုက်ပါ။ reboot ကျပြီး ပြန်တက်လာရင် ၅.၀.၂ လေးနဲ့ ဖြစ်သွားပါဘီ။

ပိုပြီးသေချာအောင် အင်တာနက်မှာ ထပ်ရှာကြည့်ပြီးမ လုပ်စေချင်ပါတယ်။