EIGRP with authentication

ဒီတစ်ခါတော့ EIGRP မှာ authentication ထည့်ပြီး configure လုပ်ကြည့်ရအောင်။ screenshot

Topology ကိုတော့အပေါ်က ပုံထဲကအတိုင်း သုံးလိုက်ပါမယ်။ R1 မှာ အောက်ကအတိုင်း configure လုပ်လိုက်မယ်။

int fa0/0

ip add 192.168.12.1 255.255.255.0

no shut

int lo0

ip add 1.1.1.1 255.255.255.0

router eigrp 10

net 192.168.12.0 0.0.0.255

net 1.1.1.0 0.0.0.255

no auto-summary

ပြီးရင် R2 မှာလဲ ဆက်ပြီး Configure လုပ်လိုက်မယ်။

int fa0/0

ip add 192.168.12.2 255.255.255.0

no shut

int lo0

ip add 2.2.2.2 255.255.255.0

router eigrp 10

net 192.168.12.0 0.0.0.255

net 2.2.2.0 0.0.0.255

no auto-summary

ဒါဆိုရင် EIGRP configuration က R1 and R2 မှာပြီးသွားပါဘီ။ ဒီအချိန်မှာ R1 ကနေ ping 2.2.2.2 source 1.1.1.1 လို့ရိုက်လိုက်ရင် အားလုံးအဆင်သွားပါလိမ့်မယ်။

ကဲဆက်ပြီး authentication ကို R2 မှာ configure လုပ်ကြည့်ရအောင်။

R2(config)#key chain EIGRP

R2(config-keychain)#key 1

R2(config-keychain-key)#key-string cisco

R2(config-keychain-key)#int fa0/0

R2(config-if)#ip authentication mode eigrp 10 md5

R2(config-if)#ip authentication key-chain eigrp 10 EIGRP

R2(config-if)#

အဲလို configure လုပ်လိုက်တာနဲ့ R2 မှာ အောက်ကလိုမျိုးတက်လာတယ်။

*Mar 1 00:05:59.835: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.12.1 (FastEthernet0/0) is down: authentication mode changed

ပြီးတော့ R1 ဘက်မှာလဲ အောက်ကလိုမျိုး မြင်ရပါလိမ့်မယ်။

*Mar 1 00:05:59.831: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.12.2 (FastEthernet0/0) is down: Interface Goodbye received *Mar 1 00:06:04.355: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.12.2 (FastEthernet0/0) is up: new adjacency *Mar 1 00:06:18.695: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.12.2 (FastEthernet0/0) is down: Auth failure

ခုဆိုရင် R1 ရဲ့ 1.1.1.1 ကနေ R2 ရဲ့ 2.2.2.2 ကို ping test လုပ်ကြည့်ရင် fail ဖြစ်ပါလိမ့်မယ်။

R1#ping 2.2.2.2 source 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

Packet sent with a source address of 1.1.1.1 ….. Success rate is 0 percent (0/5)

R1#

R1 ဘက်မှာလဲ အဆင်ပြေအောင် အဲဒီဘက်မှာလဲ authentication ကို ဆက်ပြီး configure လုပ်ရအောင်။

R1(config)#key chain EIGRP

R1(config-keychain)#key 1

R1(config-keychain-key)#key-string cisco

R1(config-keychain-key)#int fa0/0

R1(config-if)#ip authentication mode eigrp 10 md5

R1(config-if)#ip authentication key-chain eigrp 10 EIGRP

R1(config-if)#end

အဲလိုလုပ်ပြီးတာနဲ့ R1 ဘက်မှာ အောက်ကလိုမျိုးမြင်ရပါလိမ့်မယ်။

*Mar  1 01:37:36.479: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.12.2 (FastEthernet0/0) is up: new adjacency

R2 ဘက်မှာလဲ အောက်ကလိုမျိုး မြင်ရပါလိမ့်မယ်။

*Mar 1 00:05:59.835: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.12.1 (FastEthernet0/0) is down: authentication mode changed *Mar 1 01:37:36.467: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.12.1 (FastEthernet0/0) is up: new adjacency

ဒီအချိန်မှာ စောစောကလိုမျိုး ping test လုပ်ကြည့်ရအောင်။

R1#ping 2.2.2.2 source 1.1.1.1

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

Packet sent with a source address of 1.1.1.1 !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/20 ms

R1#

R2 ဘက်မှာလဲ စမ်းကြည့်လိုက်ရအောင်။

R2#ping 1.1.1.1 source 2.2.2.2

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

Packet sent with a source address of 2.2.2.2 !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12ms

R2#

ခုဆိုရင် authentication ကို R1 မှာရော R2 မှာရော configure လုပ်လိုက်တော့အားလုံးအဆင်ပြေသွားပါဘီ။

စမ်းကြည့်လိုက်ပါဦး။

Advertisements

RIP with Authentication

အရင်တုန်းက ရေးခဲ့တဲ့ RIP lab အကြောင်းတွေမှာ Authentication အကြောင်းမပါခဲ့ဘူး။ အခု ဒီနုတ်မှာတော့ RIP သုံးပြီး configure လုပ်ထားတဲ့ router တွေမှာ authentication ဘယ်လိုထည့်သလဲဆိုတာကိုပြောပြမှာဖြစ်ပါတယ်။

RIP_authentication

Topology ကိုတော့အထက်က ပုံလေးကိုပဲ သုံးထားပါတယ်။

R1 မှာ IP Address တွေကို ထုံးစံအတိုင်းပေးလိုက်ပါမယ်။

int fa0/0

ip address 192.168.12.1 255.255.255.0

no shut

int loopback 0

ip add 1.1.1.1 255.255.255.0

ပြီးရင် R1 မှာ RIP Version 2 ကို သုံးပြီး configure လုပ်လိုက်ပါမယ်။

router rip

version 2

network 192.168.12.0

network 1.1.1.0

no auto-summary

ဒါဆိုရင် R1 မှာ RIP configuration ပြီးပါဘီ။ ဆက်ပြီး R2 မှာ အဲဒီအတိုင်း Configure လုပ်လိုက်ပါမယ်။ R1 နဲ့ connect လုပ်ထားတဲ့ fa0/0 interface မှာတော့ 192.168.12.2/24 ကို ပေးလိုက်ပါမယ်။

ဒါတွေပြီးရင်တော့ RIP configuration က R1 and R2 မှာပြီးပါဘီ။ ဆက်ပြီး authentication ထည့်ရအောင်။

R1(config)#key chain RIP
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string cisco
R1(config-keychain-key)#end

R2(config)#key chain RIP
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string cisco
R2(config-keychain-key)#end

ဒီမှာဆိုရင် key chain နာမည်ကို RIP လို့သုံးလိုက်တယ်။ အဲဒီနေရာမှာကြိုက်တာ သုံးနိုင်ပါတယ်။ Router တိုင်းမှာတူစရာမလိုပါဘူး။ ပြီးတော့ authentication key ရဲ့ identifier number ကို ၁ လို့သုံးလိုက်တယ်။ တကယ်လို့ MD5 authentication ကို မသုံးဘူးဆိုရင် အဲဒီနံပါတ်လဲ တူစရာမလိုပါဘူး။ ဒီမှာတော့ အတူတူသုံးလိုက်ပါမယ်။ ဘာလို့လဲဆိုတော့ plain text authentication ရော MD5 authentication ရောသုံးမှာမို့လို့ပါ။ key-string ကတော့ ၂ ဖက်လုံးမှာ တူဖို့လိုပါတယ်။

ကဲပြီးရင် စောစောက ကျွန်တော်တို့ configure လုပ်ထားတဲ့ authentication တွေကို interface မှာ သုံးဖို့အတွက် configure ဆက်လုပ်ရအောင်။

R1(config)#int fa0/0
R1(config-if)#ip rip authentication key-chain RIP
R1(config-if)#end

R2(config)#int fa0/0
R2(config-if)#ip rip authentication key-chain RIP
R2(config-if)#end

ကဲဒါဆိုရင်ပြီးဘီ။ verify ဘယ်လိုပြန်လုပ်မလဲ။
RIP protocol ရဲ့ သဘောသဘာဝအရ routing update တွေကို every 30 seconds ကျရင် တခြား routes တွေကို ပို့တယ်။ အဲဒါကိုမြင်ချင်ရင် debug ip rip လို့ R1 မှာ ရိုက်ပြီးကြည့်ရအောင်။

ဒါတွေကတော့ R1 က R2 ဆီကိုပို့တဲ့ Routing update တွေပါ။
*Mar 1 02:00:22.775: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.12.1)
*Mar 1 02:00:22.775: RIP: build update entries
*Mar 1 02:00:22.775: 1.1.1.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 02:00:27.931: RIP: sending v2 update to 224.0.0.9 via Loopback0 (1.1.1.1)
*Mar 1 02:00:27.931: RIP: build update entries
*Mar 1 02:00:27.931: 192.168.12.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 02:00:27.939: RIP: ignored v2 packet from 1.1.1.1 (sourced from one of our addresses)

ဒါတွေကတော့ R1 က R2 ဆီကနေရတဲ့ Routing update တွေပါ။
*Mar 1 02:00:33.175: RIP: received packet with text authentication cisco
*Mar 1 02:00:33.175: RIP: received v2 update from 192.168.12.2 on FastEthernet0/0
*Mar 1 02:00:33.179: 2.2.2.0/24 via 0.0.0.0 in 1 hops
*Mar 1 02:00:35.179: RIP: sending v2 flash update to 224.0.0.9 via FastEthernet0/0 (192.168.12.1)
*Mar 1 02:00:35.179: RIP: build flash update entries – suppressing null update

အဲဒါတွေကြည့်ပြီး ဘာပြောနိုင်သလဲဆိုရင် RIP က routing update တွေကိုပို့ဖို့အတွက် multicast address 224.0.0.9 ကိုသုံးတယ်။ ပြီးတော့စောစောက ကျွန်တော်တို့ configure လုပ်တုန်းက authentication ကို plain text အနေနဲ့ပဲ ပို့တယ်။ ပိုပြီးစိတ်ချရအောင် MD5 ကိုသုံးပြီး authentication လုပ်ရအောင်။ အဲလိုလုပ်ဖို့အတွက်အောက်ကကွန်မန်းတွေထပ်ရိုက်ဖို့လိုပါတယ်။

R2(config)#int fa0/0
R2(config-if)#ip rip authentication mode md5
R2(config-if)#end

R1(config)#int fa0/0
R1(config-if)#ip rip authentication mode md5
R1(config-if)#end

အဲဒါတွေ လုပ်ြပီးရင် debug ip rip ကို ဆက်ရိုက်ပြီး routing update ဘယ်လိုပို့လဲဆိုတာကို ကြည့်ရအောင်။

*Mar 1 02:10:39.027: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.12.1)
*Mar 1 02:10:39.027: RIP: build update entries
*Mar 1 02:10:39.027: 1.1.1.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 02:10:40.851: RIP: received packet with MD5 authentication
*Mar 1 02:10:40.855: RIP: received v2 update from 192.168.12.2 on FastEthernet0/0
*Mar 1 02:10:40.855: 2.2.2.0/24 via 0.0.0.0 in 1 hops
*Mar 1 02:10:53.171: RIP: sending v2 update to 224.0.0.9 via Loopback0 (1.1.1.1)
*Mar 1 02:10:53.171: RIP: build update entries
*Mar 1 02:10:53.171: 2.2.2.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 02:10:53.175: 192.168.12.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 02:10:53.179: RIP: ignored v2 packet from 1.1.1.1 (sourced from one of our addresses)

ဒီမှာဆိုရင် authentication မှာ ဘာပေးထားတယ်ဆိုတာကို မတွေ့ရတော့ဘူး။ ကျွန်တော်တို့အဲလိုတွေ့ရတာက router ၂ ခုလုံးမှာ MD5 authentication ကို သုံးမယ်ဆိုပြီး configure လုပ်လိုက်လို့အားလုံးအဆင်ပြေတာပါ။ အဲလိုမဟုတ်ဘဲ R1 မှာပဲ MD5 သုံးပြီး R2 မှာ MD5 မသုံးဘူးဆိုရင် အောက်ကလိုမျိုးတွေ့ရပါလိမ့်မယ်။
*Mar 1 02:16:14.115: RIP: ignored v2 packet from 192.168.12.2 (invalid authentication)

May all your updates are secure with MD5 authentication.

File Permission on Linux

Linux မှာ File permission ကို ဘယ်လိုသိနိုင်မလဲ။ CLI ကနေ ls -l or ll လို့ကြည့်လိုက်ရင် အောက်ကလိုမျိုး တွေ့ရပါမယ်။

ls

အဲဒီမှာ anaconda-ks.cfg and Desktop ရဲ့ရှေ့မှာ -rw——- and drwxr-xr-x လို့ မြင်ရတယ်။ အဲဒါက ဘာလဲဆိုတာကို အောက်က ပုံလေးမှာ ရှင်းပြထားပါတယ်။

permission

ပထမဆုံး – or d က ဘာကိုပြောတာလဲဆိုရင် – ဆိုရင် ဖိုင် d ဆိုရင် ဖိုဒါ လို့ပြောတာ။ ပထမဆုံး rwx ကတော့ file owner ရဲ့ read, write and execute permisson ပါ။ ဒုတိယ rwx ကတော့ group member တွေရဲ့ read, write and execute permission ပါ။ နောက်ဆုံး rwx ကတော့ တခြား users တွေအတွက် read, write and execute permission ပါ။ ဆိုပါစို့ read permission ကို ပေးချင်ရင် r နေရာမှာ 1 လို့ permission ပေးရမယ်။ write permission ပါပေးချင်ရင် w နေရာမှာ 1 လို့ ‌permission ပေးရပါမယ်။ ‌execute permission ကို ပိတ်ထားချင်ရင်တော့ x နေရာမှာ 0 လို့ permission ပေးရပါမယ်။ ‌အားလုံးကို ပေါင်းလိုက်ရင် 110 ရတယ်။ အဲဒီ 110 က binary လိုရေးလိုက်တာပါ။ အဲဒါကို decimal ပြောင်းလိုက်ရင် ၆ ရတယ်။ အဲဒီတော့ ဖိုင်တစ်ခုကို အားလုံးအတွက်  read, write and no execute permission ပေးချင်ရင် အောက်က ကွန်မန်းကို သုံးနိုင်ပါတယ်။

ပထမဆုံး test.txt ဆိုတဲ့ ဖိုင်တစ်ခုကို create လုပ်လိုက်မယ်။ ပြီးတော့ အဲဒီဖိုင်ရဲ့ permission ကို ကြည့်လိုက်တော့ အောက်ကလိုမျိုးတွေ့ရတယ်။

[root@localhost ~]# ls -l test.txt
-rw-r–r– 1 root root 0 Jun 22 16:50 test.txt
[root@localhost ~]#

အဲဒါကို အားလုံးအတွက် ‌read, write and no execute permission ပြောင်းချင်ရင် အောက်ကလိုမျိုးပြောင်းနိုင်ပါတယ်။

[root@localhost ~]# chmod 666 test.txt
[root@localhost ~]# ls -l test.txt
-rw-rw-rw- 1 root root 0 Jun 22 16:50 test.txt
[root@localhost ~]#

ပြောင်းပြီးတော့ ပြန်စစ်ကြည့်လိုက်တော့ စောစောက ကျွန်တော်တို့ ပြောင်းလိုက်သလိုပဲ file permission က ပြောင်းသွားပါတယ်။

အဲဒီမှာတွေ့ရတဲ့ root root ဆိုတာက owner and group ပါ။ ပထမ root က file owner, ဒုတိယ root က အဲဒီဖိုင်ရဲ့ group။ အဲဒါကို ပြောင်းချင်ရင်တော့ chown command သုံးလို့ရပါတယ်။

[root@localhost ~]# ls -l test.txt
-rw-rw-rw- 1 root root 0 Jun 22 16:50 test.txt
[root@localhost ~]# chown root:nagios test.txt
[root@localhost ~]# ls -l test.txt
-rw-rw-rw- 1 root nagios 0 Jun 22 16:50 test.txt
[root@localhost ~]#

ကဲအခုတော့ ဒီလောက်ပါပဲ။ နောက်နေ့တွေကျမ user account ဘယ်လိုလုပ်မယ် group ဘယ်လိုလုပ်တယ်ဆိုတာကို ထပ်ပြီးရေးပါဦးမယ်။

NTP Server setup in CentOS

NTP server က သာမန်ကွန်ပျူတာတွေအတွက် မလိုအပ်ပေမယ့် Network Devices တွေအတွက်တော့လိုအပ်ပါတယ်။ ဘာလို့လဲဆိုတော့ တစ်ခုခုပြသနာတက်ရင် Troubleshoot လုပ်ဖို့အတွက် log တွေကို ပြန်ကြည့်တဲ့အခါ အချိန်က အားလုံးတူနေမ ပြန်စစ်တဲ့အခါ အဆင်ပြေမှာ။ မဟုတ်ရင် log တွေစစ်တဲ့အခါ မရေရာတဲ့ အဖြေတွေရပြီး ဘာဖြစ်တယ်ဆိုတာကို တိကျတဲ့အဖြေရဖို့ခက်ပါတယ်။ အဲဒါကြောင့် NTP Server ကို သုံးကြတယ်။

Windows Server မှာတော့ ဘယ်လို setup လုပ်တယ်ဆိုတာကို မစမ်းဖြစ်ခဲ့ဘူး။ မနေ့ကတော့ လုပ်ငန်းလိုအပ်မှုကြောင့် Linxu Server (CentOS) မှာ ဘယ်လို configure လုပ်တယ်ဆိုတာကို စမ်းကြည့်ဖြစ်တယ်။ အားလုံးအဆင်ပြေသွားတယ်။ အခုပို့မှာ ဘယ်လိုလုပ်ရတယ်ဆိုတာကို ပြောပြပေးမှာပါ။

ပထမဆုံး NTP daemon ကို အင်‌စတောလုပ်ပေးဖို့လိုပါမယ်။ အောက်ကကွန်မန်းနဲ့ အင်စတောလုပ်နိုင်ပါတယ်။

[root@localhost ~]# yum install ntp
Package ntp-4.2.6p5-3.el6.centos.x86_64 already installed and latest version
Nothing to do
[root@localhost ~]#

ဒီမှာတော့ အင်စတောလုပ်ပြီးသားမို့ ဘာမထပ်လုပ်စရာမလိုတော့ပါဘူး။ ကဲပြီးရင် /etc/ntp.conf ဖိုင်ကို ပြင်ပေးဖို့လိုပါတယ်။

# Hosts on local network are less restricted.
#restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap
restrict 192.168.2.0 mask 255.255.255.0 nomodify notrap
restrict 10.0.0.0 mask 255.255.255.0 nomodify notrap

# Use public servers from the pool.ntp.org project.
# Please consider joining the pool (http://www.pool.ntp.org/join.html).
server 0.centos.pool.ntp.org iburst
#server 1.centos.pool.ntp.org iburst
#server 2.centos.pool.ntp.org iburst
#server 3.centos.pool.ntp.org iburst

ဒီမှာ Hosts on local network မှာ နပ်ဝပ် ၂ ခု ထည့်လိုက်ပါမယ်။ ဆိုလိုတာက အဲဒီ နပ်ဝပ် ၂ ခုကနေ ဒီ NTP Server ကို NTP Server အနေနဲ့ အသုံးပြုနိုင်တယ်ဆိုတဲ့ သဘောပါပဲ။ ပြီးတော့ use public servers from the pool.ntp.org project အောက်မှာ public server တစ်ခုကို on လိုက်ပါမယ်။ ရှေ့ဆုံးမှာရှိတဲ့ # လေးကို ဖြုတ်လိုက်ယုံပါပဲ။ ဒီနေရာမှာ တခြား NTP Server address တွေကိုလဲ သုံးနိုင်ပါတယ်။

ပြီးရင် NTP service ကို restart လုပ်ပေးဖို့လိုပါတယ်။

service ntpd restart

ပြီးရင် စက်ဖွင့်လိုက်တိုင်း ntp service ကို စတင်ဖို့အတွက် ntp service ကို start-up မှာ on ပေးဖို့လိုပါတယ်။ အဲဒီလိုဖြစ်ဖို့အတွက် အောက်ကကွန်မန်းကို သုံးပေးဖို့လိုပါတယ်။

chkconfig ntpd on

ခုဆိုရင်တော့ ဆာဗာဘက်မှာတော့ အားလုံးပြီးဘီ။ ကဲ Windows PC ကနေ စမ်းကြည့်ရအောင်။

CLOCK

date/time ကို ကလစ်ပြီး change date and time setting ကို ကလစ်လိုက်မယ်။ ပြီးရင် Internet Time tab ကို သွားပြီး Change Setting ကို သွားလိုက်မယ်။ ပြီးရင် Synchronize with an internet server ကို ရွေးလိုက်ပြီး စောစောက configure လုပ်ထားတဲ့ ဆာဗာလိပ်စာကို ‌ရိုက်လိုက်မယ်။ ပြီးရင် update now ကို ကလစ်လိုက်ရင် အောက်ကပုံထဲက အတိုင်းမြင်ရလိမ့်မယ်။

NTP

အဆင်ပြေရင် စမ်းကြည့်လိုက်ပါဦး။

Singapore မှာ ခရီးသွားရင်း ပိုက်ဆံရှာကြမယ်

ခရီးသွားရင်း ပိုက်ဆံရှာကြမယ်ဆိုလို့တစ်မျိုးမထင်ကျနဲ့ဦး စင်ကာပူမှာ ez link card သုံးပြီး ကားစီး ရထားစီးရင်း ပိုက်ဆံဝင်နိင်တဲ့နည်းလမ်းတစ်ခုကို ပြောပြပေးမှာပါ။ သိတဲ့သူရှိသလို မသိတဲ့သူလဲ ရှိနိုင်ပါတယ်။

အခုအစီအစဥ်ကိုတော့ LTA, Transitlink and SMRT ကနေ အထောက်အပံ့ပေးထားတာပါ။

စင်ကာပူမှာ ခရီးသွားဖို့အတွက် Ez link ကဒ်ကလေးတွေကို သုံးရတယ်။

ဘယ်လိုလဲဆိုတော့ Ez Link card ကို သုံးပြီး ခရီးသွားတာနဲ့အမျှ Point တွေရလာတယ်။ ပြီးရင် အဲဒီ ပွိုင့်တွေကိုသုံးပြီးတော့ Spin to Win ဆိုတဲ့ကစားနည်းကို ကစားရမှာ ဖြစ်ပါတယ်။ Spin တစ်ခါလုပ်ရင် 10 point လိုပါတယ်။ အဲဒီကစားနည်းက ငယ်ငယ်တုန်းက အန်စာတုန်းပစ်ပြီး ကျတဲ့နံပါတ်အတိုင်း ၁ ကနေစပြီး ပန်းတိုင်ကို ရောက်အောင်သွားရတဲ့ ကစားနည်းပါ။ ၁ ကနေ ပန်းတိုင်အတွင်း ပါဝါကို ရပြီးလှေခါးနဲ့တက်သွားသလို မြွေကိုက်ပြီး အောက်ရောက်သွားသလိုပဲ ဒီမှာဆိုရင် point ‌ကလေးတွေ လှေခါးတွေ တွင်းတွေ ပိုက်ဆံတွေ ပါပါတယ်။ ပိုက်ဆံရရင် အဲဒီပိုက်ဆံကို ကိုယ်ထည့်ထားတဲ့  MRT Card နံပါတ်တူတဲ့ ကဒ်ထဲကို ပိုက်ဆံထည့်ပေးမှာပါ။ ဆိုလိုတာက register လုပ်ထားတဲ့ ကဒ်ထဲကိုပဲ ထည့်ပေးမှာပါ။ တခြားကဒ်ထဲကို ထည့်မပေးပါဘူး။ တစ်ကယ်လို့ ကဒ်ပျောက်သွားလို့ တခြားကဒ်အသစ်တစ်ခု ဝယ်လိုက်တယ်ဆိုရင် အရင်ကဒ်နံပါတ်ကို ဖျက်ပြီး နောက်ကဒ်အသစ်ကို ပြန်ထည့်လိုက်ရင် နိုင်ထားသမျှပိုက်ဆံနဲ့ ပွိုင့်တွေကို နောက်ကဒ်အသစ်ထဲကို ထည့်ပေးမှာ ဖြစ်ပါတယ်။ card activate ဖြစ်ဖို့တော့ ၃ ရက် ၄ ‌ရက်လောက် စောင့်ရပါတယ်။

စိတ်ဝင်စားလို့ register လုပ်ချင်ရင်တော့ အောက်ကလင့်ကနေ register လုပ်ပေးကြပါနော်။ ကျွန်တော်ပွိုင့်ရအောင်လို့ပါ။

https://travelsmartrewards.sg/r/MNbaPUGg/

အဲဒီလင့်ကိုသွားပြီး အီးမေးလိပ်စာနဲ့ password ရိုက်ပြီး register လုပ်နိုင်ပါတယ်။ ပြီးရင် ပုံထဲကအတိုင်း နာမည် အသက် အလုပ်အကိုင် နဲ့ ကဒ်နံပါတ်ကို ဖြည့်ပြီး I agreed ကို ကလစ်လိုက်ပါ။

SMRT form

ပြီးရင် စောစောက ထည့်လိုက်တဲ့ အီးမေးဆီကို မေးပို့လာပါလိမ့်မယ်။ အဲဒါကလဲ ထည့်လိုက်တဲ့အီးမေးလိပ်စာမှန်မမှန် ပြန်ပြီး confirm လုပ်တဲ့သဘောပါပဲ။ အဲဒီမှာပါတဲ့လင့်ကတစ်ဆင့် confirm လုပ်ပြီး လုပ်ထားတဲ့အကောင့်ကို active လုပ်နိုင်ပါတယ်။

အဲဒါတွေလုပ်ပြီးရင် လုပ်ထားတဲ့အကောင့်ကိုဝင်ပြီး setting ကနေတဆင့် spin the game ကို auto လား manual လားဆိုတာကို setup လုပ်နိုင်ပါတယ်။ တကယ်လို့ပိုက်ဆံရပြီဆိုရင် ဒီလနိုင်တာကို နောက်လမှာ ထုတ်ယူနိုင်ပါတယ်။

ကဲဒီလောက်ဆိုရင်တော့ တီးမိခေါက်မိရှိပြီထင်ပါတယ်။ စင်ကာပူမှာနေပြီး ez link card နဲ့ ရထား bus ကားနဲ့ ခရီးသွားတယ်ဆိုရင်တော့ အကောင့်တစ်ခုလောက်လုပ်ထားသင့်ပါ‌ကြောင်း ကိုယ်ပိုင်ကားရှိတယ်ဆိုရင်တော့ ဒီပို့က အပိုဖြစ်နေပါလိမ့်မယ်။

စမ်းကြည့်လိုက်ပါဦး… ဒါနဲ့စကားမစပ် အကောင့်လုပ်ရင် ကျွန်တော့်ပေးထားတဲ့လင့်လေးကနေလုပ်ပေးပါနော်။

https://travelsmartrewards.sg/r/MNbaPUGg/